Thursday, 29 October 2009

Wireshark on Gentoo hardened

If compiling wireshark bails out with the following error:

checking for GTK+ - version >= 2.4.0... no
*** Could not run GTK+ test program, checking why...
*** The test program failed to compile or link. See the file config.log for the
*** exact error that occured. This usually means GTK+ is incorrectly installed.
configure: error: GTK+ 2.4 or later isn't available, so Wireshark can't be compiled

Disable the 'profile' flag as per this bug. So the magic command is:

USE="-profile" emerge wireshark

Happy sniffing! ;]

1 comment:

  1. This comment has been removed by a blog administrator.

    ReplyDelete

Have your say: